Dashboard Creative Upload Feature Down
Incident Report for Chartboost
Resolved
The malfunction identified with our creative upload process is now successfully resolved.
Posted 5 months ago. Apr 01, 2019 - 02:57 PDT
Investigating
The creative upload feature is currently not working. We are working on having this resolved as soon as possible.
Posted 5 months ago. Apr 01, 2019 - 01:48 PDT
This incident affected: Dashboard.